SUSE Support

Here When You Need Us

Installing Oracle Java on SLED/SLES 11 SP2

This document (7010472) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Desktop 11 SP2
SUSE Linux Enterprise Server 11 SP2
Oracle Java
Mozilla Firefox browser

Situation

As a result of a license change SUSE is no longer able to provide Oracle/Sun Java in the distribution or through the update channels.  As a result Java will need to be downloaded from the java.com site and manually installed.

This also means that we cannot provide support for Oracle Java.  Any support issues should be directed to Oracle.  The following information is provided as a potential solution but is not guaranteed.

Resolution

1.  Use YaST -> Software -> Software Management and remove all previous versions of Java (e.g. java-1_6_0-sun, icedtea-web).  Do not remove the openjdk version of Java if you have it installed.  This is required for Java functionality in LibreOffice.

2.  Download Oracle Java

Check if you have i586 or x86_64 version of Mozilla Firefox (this can be different from the architecture of the system). The easiest way is to open a console and type

   rpm -q --queryformat '%{arch}\n' MozillaFirefox

If x86_64 appears, use the version marked as "Linux x64 RPM".

Visit http://java.com/ and click on Free Java Download.  Download the "Linux RPM" (32 bit) or "Liinux x64 RPM" (64 bit) as appropriate.

3.  As the root user install the downloaded rpm from a terminal by using the command:

   rpm -Uvh <file-name>

Of course replace <file-name> with the path and name of the rpm file downloaded from java.com.

4.  Enable the plugin for Firefox.

Logged in as the user that will be running firefox open a terminal window and do the following:

   mkdir -v ~/.mozilla/plugins
(if it already exists that's okay)

   rm ~/.mozilla/plugins/libnpjp2.so

   ln -s /usr/java/jre1.7.0_05/lib/amd64/libnpjp2.so ~/.mozilla/plugins/
(The "jre1.7.0_05" will need to match the version just installed)

5.  Close all instances of the Firefox browser then open it up again.

Browse to http://java.com/en/download/installed.jsp to verify that java is installed properly.

Cause


Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7010472
  • Creation Date: 17-Jul-2012
  • Modified Date:28-Sep-2022
    • SUSE Linux Enterprise Desktop
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.