SUSE Support

Here When You Need Us

Unattended Upgrade to SLES11 Reinstalls Server

This document (7010965) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 11 Service Pack 1 (SLES)
SUSE Linux Enterprise Server 11 Service Pack 2 (SLES)

Situation

After performing an unattended upgrade from SLES10 SP4 to SLES11 SP1 or SP2, the filesystem was reformatted and SLES11 was installed new instead of upgrading the server.

Even though the server was upgraded using the autoyast autoupg.xml control file, the server was still reinstalled instead of being upgraded.

Resolution

Use the autoupgrade=1 kernel parameter in the Boot Options line or the kernel parameter in the /boot/grub/menu.lst file.

For example,
1. Insert the SLES11 SP2 DVD into your SLES10 SP4 server.
2. Boot from the DVD and select "Installation"
3. The cursor is already in the "Boot Options" window.
4. Make sure you include the autoupgrade=1 parameter in the Boot Options window to start the unattended upgrade process.

Cause

Per documentation, the SLES11 installation process needs to be told to do an upgrade instead of a normal install. This is done by adding the autoupgrade=1 kernel parameter.

Additional Information

Is there any way to roll back the automatic install of the server after performing the unattended upgrade without the autoupgrade=1 switch? No. You will need to reinstall the server. Just make to use the autoupgrade=1 switch for future server upgrades.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7010965
  • Creation Date: 19-Oct-2012
  • Modified Date:03-Mar-2020
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.