SUSE Support

Here When You Need Us

SUSE Manager Configuration - Bootstrap - unhandled exception

This document (000020815) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Manager Server 4.3
SUSE Manager Server 4.2


Situation

When updating the SUSE Manager bootstrap configuration the webUI shows a "Unhandled error" message.

Checking the file "/var/log/rhn/rhn_web_ui.log" shows the following:
 

2022-10-19 07:55:51,403 [ajp-nio-0:0:0:0:0:0:0:1-8009-exec-2] ERROR com.redhat.rhn.manager.satellite.SystemCommandExecutor - Error encountered executing (args=[/usr/bin/sudo, /usr/bin/rhn-bootstrap, --hostname=<your_SUSE_Manager_hostname>, --ssl-cert=/srv/www/htdocs/pub/rhn-org-trusted-ssl-cert-<version>.noarch.rpm])
2022-10-19 07:55:51,403 [ajp-nio-0:0:0:0:0:0:0:1-8009-exec-2] ERROR com.redhat.rhn.manager.satellite.SystemCommandExecutor - Error message from process: 
We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

sudo: a terminal is required to read the password; either use the -S option to read from standard input or configure an askpass helper
sudo: a password is required


Running "/usr/bin/rhn-bootstrap" via "/usr/bin/sudo" fails as there is no permission for user tomcat within the configuration.

Resolution

Ensure the file "/etc/sudoers.d/spacewalk" exists, contains the proper configuration and is called from the main sudoers file "/etc/sudoers" via the include directive:

"@includedir /etc/sudoers.d"

Cause

SUSE Manager provides sudo configuration in the file "/etc/sudoers.d/spacewalk", but either this file does not exist or is not being called from the main sudoers file "/etc/sudoers".

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000020815
  • Creation Date: 19-Oct-2022
  • Modified Date:25-Apr-2024
    • SUSE Manager Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.