SUSE Support

Here When You Need Us

Wrong timezone after update

This document (7018417) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 12 Service Pack 1 (SLES 12 SP1)
SUSE Linux Enterprise Server 12 Service Pack 2 (SLES 12 SP2)
SUSE Linux Enterprise Server 12 Service Pack 3 (SLES 12 SP3)
SUSE Linux Enterprise Server 12 Service Pack 4 (SLES 12 SP4)
SUSE Linux Enterprise Server 12 Service Pack 5 (SLES 12 SP5)
SUSE Linux Enterprise Server 15 (SLES 15)
SUSE Linux Enterprise Server 15 Service Pack 1 (SLES 15 SP1)
SUSE Linux Enterprise Server 15 Service Pack 2 (SLES 15 SP2)
SUSE Linux Enterprise Server 15 Service Pack 3 (SLES 15 SP3)
SUSE Linux Enterprise Server 15 Service Pack 4 (SLES 15 SP4)

Situation

A system where the timezone is set via timedatectl shows the wrong timezone after updating the system.

Resolution

One has to decide which mechanism to use, whether timedatectl or the traditional approach via /etc/sysconfig/clock.

If the organization decides to use timedatectl, deleting /etc/sysconfig/clock is a valid approach. 

Cause

After an update of the timezone package the system will apply the setting set in /etc/sysconfig/clock. timedatectl does not use or change this file.
 
There are two separate mechanisms for changing the timezone data on a system:
 
- Setting the timezone via /etc/sysconfig/clock and linking /usr/share/zoneinfo/$TIMEZONE to /etc/localtime is the traditional one, used by YaST.
- Then also timedatectl, the modern solution invented by systemd.

Additional Information

There is already a change planned for salt, which will force the time state to change /etc/sysconfig/clock.
In the long run /etc/sysconfig/clock will be obsolete and the affected parts of YaST rewritten.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7018417
  • Creation Date: 23-Dec-2016
  • Modified Date:06-Oct-2021
    • SUSE Linux Enterprise Server
    • SUSE Linux Enterprise Server for SAP Applications

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.