SUSE Support

Here When You Need Us

zypper se -s shows installed packages as (System Packages)

This document (7022656) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Manager 3.1

Situation

When searching for packages using zypper se -s <packagename>, the package is listed first as (System Packages) and second with the repository name:

sles12sp3:~ # zypper se -s mcelog
[...]
Loading repository data...
Reading installed packages...

S | Name   | Type    | Version   | Arch   | Repository
--+--------+---------+-----------+--------+---------------------------
i | mcelog | package | 1.48-1.13 | x86_64 | (System Packages)
v | mcelog | package | 1.48-1.13 | x86_64 | SLES12-SP3-Pool for x86_64


In addition, when running "zypper dup" the command lists a bunch of packages to be reinstalled despite the fact they are at the latest level.
This could possibly lead to a broken system.

Resolution

Fixed as of spacewalk-backend >= 2.7.73.12-2.16.2.

https://download.suse.com/Download?buildid=giNV9QlhhSE~

- Use GTM for rpm build_time (bsc#1078056)

Cause

Different package timestamps in the database and repository metadata.

Additional Information


Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7022656
  • Creation Date: 13-Feb-2018
  • Modified Date:03-Mar-2020
    • SUSE Manager

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.