SUSE Support

Here When You Need Us

The scatool fails to email reports

This document (000021180) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 15 SP4

Situation

When attempting to email the Supportconfig Analysis Report (SCA Report) with the scatool, the following error is observed:

# scatool -e root scc_sles15sp4_230622_1143_Updated.txz
...
Emailing SCA Report To:        root
/usr/lib64/python3.6/re.py:212: FutureWarning: split() requires a non-empty pattern match.
  return _compile(pattern, flags).split(string, maxsplit)
Traceback (most recent call last):
  File "/usr/lib/sca/python/scatool.py", line 1690, in <module>
    analyze(analyzeFile)
  File "/usr/lib/sca/python/scatool.py", line 1580, in analyze
    emailSCAReport(supportconfigPath)
  File "/usr/lib/sca/python/scatool.py", line 986, in emailSCAReport
    emailMsg = email.MIMEMultipart.MIMEMultipart('alternative')
AttributeError: module 'email' has no attribute 'MIMEMultipart'

 

Resolution

Reported to engineering. Please open a case to request a PTF.

Cause

Python3 email libraries changed and the scatool needs fixing.

Status

Reported to Engineering

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000021180
  • Creation Date: 22-Aug-2023
  • Modified Date:22-Aug-2023
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.