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Client does not appear in system list after bootstrapping and errors about rendering the roster file appear in the Salt logs

This document (000021713) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Manager Server 5.0

SUSE Manager Server 4.3


Situation

After bootstrapping a system and accepting the Salt key, the bootstrapped system never appears in the system list and has no enabled repositories. Messages in the Salt log file /var/log/salt/api on the SUSE Manager indicate an issue with the roster file, for example:

2025-01-02 05:15:24,715 [salt.roster      :104 ][ERROR   ][22190] Unable to render roster file: found character '%' that cannot start any token; line 1

 

And in the file '/etc/salt/master' or in a file in the drop-in configuration directory /etc/salt/master.d, the setting 'renderer' is applied and does not include 'jinja', for example:

renderer: yaml|gpg

In this example, the setting is applied because it has no leading '#' and so is not commented out.

To check how the 'renderer' setting is applied in the configuration files, run the following grep command on the SUSE Manager server:

grep -R '^renderer' /etc/salt

Resolution

Delete or comment out the line that applies the 'renderer' setting, or add 'jinja' to the list of renderers.

To comment out the line, add '#' to the beginning so it looks like this:

#renderer: yaml|gpg

Or, you can change the setting so it includes jinja, like this:

renderer: jinja|yaml|gpg

 

The salt-master service on the SUSE Manager server must be restarted to finish applying this change. You can restart the service with this command:

systemctl restart salt-master

Cause

The Jinja renderer is needed to bootstrap this system but SUSE Manager has been configured to not use this renderer. Jinja is already set by default as one of the renderers when the 'renderer' Salt setting is not applied, but in this case a setting has been added that excluded the Jinja renderer.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000021713
  • Creation Date: 20-Feb-2025
  • Modified Date:27-Feb-2025
    • SUSE Manager Server

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