SUSE Support

Here When You Need Us

Apache ocf resource failing to start in cluster.

This document (7023202) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise High Availability Extension 12
SUSE Linux Enterprise High Availability Extension 11 Service Pack 4

Situation

Setting up Apache2 with apache ocf resource script and it fails to start.
Error: Failed to access httpd status page

Logs:
lrmd[18156]:   notice: executing - rsc:Apache action:start call_id:29404
apache(Apache)[4060]: ERROR: Failed to access httpd status page.
apache(Apache)[4060]: INFO: Attempting graceful stop of apache PID 4595
apache(Apache)[4060]: INFO: apache stopped.
lrmd[18156]:   notice: Apache_start_0:4060:stderr [ ocf-exit-reason:Failed to access httpd status page. ]

Resolution

Need to add the "mod_status_module" to the Apache configuration file.
/etc/apache2/loadmodule.conf
LoadModule status_module                  /usr/lib64/apache2-prefork/mod_status.so

Optional.
You can also just configure the lsb startup script in the cluster to stop / start / monitor the service instead of using the OCF script.

Cause

The default apache configuration does not load the status_module and the ocf:heartbeat:apache script relies on the statusurl to monitor whether apache2 service is responding to requests.

Additional Information

Script location: ocf:heartbeat:apache
/usr/lib/ocf/resource.d/heartbeat/apache

crm shell command to see more information about resource agent
# crm ra info apache

Example of cluster configuration primitive
primitive apache2 apache \
        params statusurl="http://localhost/server-status" \
        op start interval=0 timeout=40 \
        op stop interval=0 timeout=60 \
        op monitor interval=10 timeout=20 \
        meta target-role=Started

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7023202
  • Creation Date: 24-Jul-2018
  • Modified Date:03-Mar-2020
    • SUSE Linux Enterprise High Availability Extension

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.