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Corosync Cluster Engine Failing to Startup

This document (7024310) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise High Availability Extension 11
SUSE Linux Enterprise High Availability Extension 12
SUSE Linux Enterprise High Availability Extension 15

Situation

Corosync is not starting and reporting similar error in system log: 

Dec 02 12:29:12 ha2 corosync[23833]:   [QB    ] Denied connection, is not ready (23833-23825-16)

Resolution

To fix above error:

1) make sure the corosync network interface is configured and running. 
2) make sure both nodes have the same corosync authkey. This can be recreated via "corosync-keygen" command.

Cause

This could be happen because of two reasons:

1) The network interface used for this ring is down or not configured. And this could be seen in the corosync logs.

Dec 02 12:29:11 ha2 corosync[23833]:   [TOTEM ] The network interface is down.

2) The system have different /etc/corosync/authkey than the other node. This can be seen on other node logs.

Dec 02 14:17:12 ha3 corosync[3273]:   [TOTEM ] Digest does not match
Dec 02 14:17:12 ha3 corosync[3273]:   [TOTEM ] Received message has invalid digest... ignoring.
Dec 02 14:17:12 ha3 corosync[3273]:   [TOTEM ] Invalid packet data

Additional Information


Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7024310
  • Creation Date: 03-Dec-2019
  • Modified Date:03-Mar-2020
    • SUSE Linux Enterprise High Availability Extension

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