SUSE Support

Here When You Need Us

Using "lspci" in rules.xml script does not work (SLES 15 SP2->SP3 regression)

This document (000020376) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 15 SP3

Situation

Customer has an autoyast rules.xml file with a custom script that runs “lspci” and looks for the string “VGA".  This works fine on SLES 15 SP2, but on SLES 15 SP3, at the time that the rules.xml script runs, the lspci output does not contain any strings like “VGA"; it only contains class and device IDs. 

- By default, lspci uses the /usr/share/pci.ids file to determine class and device names.
- The /usr/share/pci.ids file is a link to /usr/share/pci.ids.d/pci.ids.dist
- But at the time that an autoyast rules.xml script runs, the /usr/share/pci.ids->/usr/share/pci.ids.d/pci.ids.dist link does not exist.
- So if a rules.xml script calls “lspci” and relies on the output containing class or device names, it will fail.
 

Resolution

Change any affected rules.xml script to use “lspci -i /usr/share/pci.ids.d/pci.ids.dist” instead of just “lspci”.
 

Cause

Change in the hwdata package

Additional Information

Expected fix in SUSE Linux Enterprise Server 15 SP3 QU1.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000020376
  • Creation Date: 01-Sep-2021
  • Modified Date:01-Sep-2021
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.