SUSE Support

Here When You Need Us

No core dump written after kernel update

This document (000020973) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 15 SP3

Situation

kdump is configured and started

# /bin/systemctl status kdump.service
 kdump.service - Load kdump kernel and initrd
     Loaded: loaded (/usr/lib/systemd/system/kdump.service; enabled; vendor preset: disabled)
     Active: active (exited) since Tue 2023-01-01 00:00:47 UTC; 3min 52s ago
    Process: 1234 ExecStart=/lib/kdump/load.sh --update (code=exited, status=0/SUCCESS)
   Main PID: 1234 (code=exited, status=0/SUCCESS)

Jan 01 00:00:46 linux-test-server systemd[1]: Starting Load kdump kernel and initrd...
Jan 01 00:00:47 linux-test-server systemd[1]: Finished Load kdump kernel and initrd.

System got updated to:

kernel 5.3.18-150300.59.106

Resolution

Fixed in kernel version 5.3.18-150300.59.112
 

Cause

Following error message can be found in dmesg output:
[  259.740743] BUG: unable to handle page fault for address: ffffffffffffffc8

 

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000020973
  • Creation Date: 14-Feb-2023
  • Modified Date:20-Mar-2023
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.