SUSE Support

Here When You Need Us

Autoyast error during auto-installation of SLES 15 from usb stick: „Repository not found“

This document (000021410) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 15

Situation

During the auto-installation started from an usb stick the media-url for repositories are not found e.g. referenced by label.

 

Resolution

To reference an repo from iso image on an unknown device you can use "relurl://":
    <add_on_products t="list">
      <listentry>
        <media_url><![CDATA[relurl://]]></media_url>
        <product>sle-module-basesystem</product>
        <product_dir>/Module-Basesystem</product_dir>
      </listentry>

 

Cause

The label set for the iso image is set for disk and each partition and therefore partition containing the repo cannot be found:

lsblk
LABEL                  NAME
...
SLE-15-SP5-Full-x86_64 sdb
SLE-15-SP5-Full-x86_64 ├─sdb1
SLE-15-SP5-Full-x86_64 └─sdb2

 

Additional Information

More details for media access url can be found here:

https://doc.opensuse.org/projects/libzypp/HEAD/classzypp_1_1media_1_1MediaManager.html#MediaAccessUrl

https://doc.opensuse.org/projects/autoyast/

 

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000021410
  • Creation Date: 22-Mar-2024
  • Modified Date:04-Jun-2024
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.