SUSE Support

Here When You Need Us

HAE Resources are not managed and won't failover

This document (7012114) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise High Availability Extension 11 (HAE)
SUSE Linux Enterprise Server 11

Situation

Cluster resources are not being managed.
Cluster resources are not starting.

crm_mon shows resources like

 Resource Group: apache2
     webip    (ocf::heartbeat:IPaddr):    Started hn2 (unmanaged)
     websrv    (ocf::heartbeat:apache):    Started hn2 (unmanaged)

# cibadmin -Q --scope crm_config
<crm_config>
  <cluster_property_set id="cib-bootstrap-options">
    <nvpair id="cib-bootstrap-options-no-quorum-policy" name="no-quorum-policy" value="ignore"/>
    <nvpair id="cib-bootstrap-options-placement-strategy" name="placement-strategy" value="balanced"/>
    <nvpair id="cib-bootstrap-options-dc-version" name="dc-version" value="1.1.6-b988976485d15cb702c9307df55512d323831a5e"/>
    <nvpair id="cib-bootstrap-options-cluster-infrastructure" name="cluster-infrastructure" value="openais"/>
    <nvpair id="cib-bootstrap-options-expected-quorum-votes" name="expected-quorum-votes" value="2"/>
    <nvpair id="cib-bootstrap-options-last-lrm-refresh" name="last-lrm-refresh" value="1365549310"/>
    <nvpair id="cib-bootstrap-options-maintenance-mode" name="maintenance-mode" value="true"/>
  </cluster_property_set>
</crm_config>

Resolution

Turn maintenance mode off.
# crm configure property maintenance-mode=false

Cause

The cluster was in maintenance mode.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7012114
  • Creation Date: 09-Apr-2013
  • Modified Date:28-Sep-2022
    • SUSE Linux Enterprise High Availability Extension
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.