SUSE Support

Here When You Need Us

Random lock up or hang when in Gnome or KDE

This document (7014951) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Desktop 11 (SLED 11)
SUSE Linux Enterprise Server 11 (SLES 11)
Intel Sandy Bridge GPU

Situation

While a user is in Gnome or KDE a lockup or hang of the system can happen randomly and a black screen is displayed.  It seems to be more common when the system has been sitting idle for some time and then becomes active, but can also happen when in constant use.

Resolution

Add the following as a kernel parameter in YaST-->System-->Boot Loader.  Edit the default selection and add the parameter to "Optional Kernel Command Line Parameter".  Alternatively, edit /boot/grub/menu.lst directly.

i915.i915_enable_rc6=0

Cause

RC6 technology provides a power saving low consumption state for the GPU and has been enabled on later kernel versions.  Kernel versions later than 3.0.42-0.7 are causing a problem with the Sandy Bridge chipset that can result in a lock up.  Adding the kernel parameter above disables the RC6 functionality and avoids the problem.  A fix has been submitted upstream which disables it for the Sandy Bridge chipset and should be provided in a future update.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7014951
  • Creation Date: 23-Apr-2014
  • Modified Date:28-Sep-2022
    • SUSE Linux Enterprise Desktop
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.