SUSE Support

Here When You Need Us

SLE 15 - Configure a static network address while in the Rescue System

This document (7023891) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 15 - Rescue System

Situation

System need to be booted into Rescue System and network access is needed.

Resolution

With SLE15 the "ip" command is used to setup an available network interface.
 
Assign a Static Address
ip a add {ip_addr/mask} dev {interface}
Example to assign 192.168.1.200/255.255.255.0 to eth0
ip a add 192.168.1.200/255.255.255.0 dev eth0
OR
ip a add 192.168.1.200/24 dev eth0
 
Bring Up The Network Interface
ip link set dev {device}  {up|down}
Example to bring up eth0 interface
ip link set dev eth0 up

Assign a Default Gateway
ip route add default via {gateway_addr}
Example to set 192.168.1.254 as the default gateway
ip route add default via 192.168.1.254
 
Assign Additional Static Routes (if needed)
ip route add {network} via {gateway_addr}
Example to set 192.168.1.254 as the gateway for subnet 192.168.1.0
ip route add 192.168.1.0/24 via 192.168.1.254
 
 
At this point there should be connectivity, however if a change is needed the assigned IP address can be removed, so a new one can be used.
ip a del {current_ip_addr} dev {device}
Example deleting 192.168.1.200 from eth0
ip a del 192.168.1.200 dev eth0
 
The routes can also be removed.
ip route del {gateway_addr}
OR
ip route del {network} dev {device}
Example removing default gateway 192.168.1.254
ip route del 192.168.1.254
Example removing 192.168.1.0 from eth0
ip route del 192.168.1.0/24 dev eth0

Cause

Current Linux releases have moved from "ifconfig" to "ip" for CLI configuration of the network interfaces.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7023891
  • Creation Date: 22-May-2019
  • Modified Date:24-Apr-2023
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.