SUSE Support

Here When You Need Us

Offline upgrade to SLES 15 SP2 with LVM and Mulitpath may result in an error.

This document (000019897) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 15 SP2

Situation

SLES 15 SP2 off-line upgrade on a system with multipathing and LVM can
result in the error: 
"The volume Group /dev/system is incomplete because some physical volumes are missing.  Incomplete Volume Groups are not visible in the partitioner and will be deleted."

Resolution

A fix for this issue will made available in a future Quarterly Update ISO.  The fix is to yast2-network-4.2.96-3.49.1 which will be found in SUSE Linux Enterprise Module for Basesystem 15-SP2 and SUSE Linux Enterprise Installer 15-SP2.

The workaround is to add "ifcfg=eth0=dhcp" as a boot option from the ISO boot menu.
 

Cause

YaST tries to come up with a network configuration (via DHCP). As part of this process, it tries to find out which "start mode" it should use. It verifies whether the "/" filesystem is on NFS, so it "accidentally" triggers a probing of the storage devices with not previous multipath activation.

As a workaround, you could add the "ifcfg=eth0=dhcp" option when booting the installer.  This will cause YaST to use the network configuration from Linuxrc thus skipping the failing process described above.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000019897
  • Creation Date: 04-Mar-2021
  • Modified Date:11-Mar-2021
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.