"RepoMDError: Cannot access repository" when syncing Red Hat (native) channels through CDN in SUSE Manager
This document (000020574) is provided subject to the disclaimer at the end of this document.
Environment
SUSE Manager 4.1
Situation
File 'repomd.xml' from repository 'rhel-x86_64-server-7-os' is unsigned, continue? [yes/no] (no): no error]
10:38:23 RepoMDError: Cannot access repository. Repository 'rhel-x86_64-server-7-os' is invalid. ...
Valid metadata not found at specified URL
Resolution
Other conflicts could be regarding networking: connections to the CDN URL (usually cdn.redhat.com) should be bypassed in any proxy or firewall on the network, and obviously the proxy (in case one needs to be used) should be properly set up in the SUSE Manager, in both Yast configuration ("yast proxy") and the SUSE Manager web-UI (admin menu, setup wizard, http proxy). Both configurations have an option to be tested.
Cause
As for the other possible problems, a network connection is always needed. If there's a firewall blocking connections, or a proxy that has not been properly set up, it will not be possible to download anything from the CDN.
Additional Information
https://documentation.suse.com/suma/4.2/en/suse-manager/client-configuration/clients-rh-cdn.html
https://documentation.suse.com/external-tree/en-us/suma/4.1/suse-manager/client-configuration/clients-rh-cdn.html
Please notice that this article is not relevant for customers using SUSE Linux Enterprise Server with Expanded Support.
Disclaimer
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- Document ID:000020574
- Creation Date: 01-Feb-2022
- Modified Date:04-Feb-2022
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- SUSE Manager
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