SUSE Support

Here When You Need Us

After upgrading to SLES15 SP3, SSSD fails to start with WARNING: Module [memberof] not found - do you need to set LDB_MODULES_PATH?

This document (000020764) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 15 SP3

Situation

After upgrading from SLES15 SP2 to SLES15 SP3, sssd service fails to start.
The following error messages can be seen in the logs:
(2022-08-10 20:48:44): [sssd] [ldb] (0x0010): WARNING: Module [memberof] not found - do you need to set LDB_MODULES_PATH?
(2022-08-10 20:48:44): [sssd] [ldb] (0x0010): Unable to load modules for /var/lib/sss/db/cache_ict.kerryad.com.ldb: (null)

Resolution

1) Update to the latest version of sssd and sssd-common:
zypper up sssd sssd-common
If during the update process a message "Package 'sssd' is not installed" appears, reinstall sssd and sssd-common packages:
zypper in -f sssd sssd-common

2) Also update the system to the latest packages version:
zypper patch
Reboot the system if needed.​​​​​​

Start sssd service:
systemctl start sssd.service

Verify if sssd service is started with:
systemctl status sssd.service


Cause

After the upgrade from SLES15 SP2 to SLES15 SP3, ldb, an LDAP-like embedded database where the local cache is stored, is not able to load the required module memberof.so.
The /usr/lib64/ldb2/modules/ldb/memberof.so module is included in sssd-common rpm which needs to be updated to the latest version.

Additional Information

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000020764
  • Creation Date: 14-Sep-2022
  • Modified Date:14-Sep-2022
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.