Loading kdump-initrd after a kernel update fails with "no kdump initial ramdisk found"
This document (7018428) is provided subject to the disclaimer at the end of this document.
Environment
Situation
After a kernel update and reboot of the system the following message will be seen:
linux-7fro:~ # journalctl -u kdump.service -- Logs begin at Fri 2016-12-30 09:26:00 CET, end at Fri 2016-12-30 09:26:35 CET. -- Dec 30 09:26:02 linux-7fro systemd[1]: Starting Load kdump kernel on startup... Dec 30 09:26:03 linux-7fro load.sh[758]: No kdump initial ramdisk found. Tried to locate /boot/initrd-3.12.67-60.64.21-default-kdump. Dec 30 09:26:03 linux-7fro systemd[1]: kdump.service: main process exited, code=exited, status=6/NOTCONFIGURED Dec 30 09:26:03 linux-7fro systemd[1]: Failed to start Load kdump kernel on startup. Dec 30 09:26:03 linux-7fro systemd[1]: Unit kdump.service entered failed state.
Resolution
linux-7fro:~ # cat /sys/kernel/kexec_crash_loaded
1
If the result is '1' the kdump kernel has been loaded and all should work as expected.
Cause
/usr/lib/systemd/system/kdump.service
is started it detected that no initrd<kernel-version>-kdump is available in /boot.
The initrd for the kdump kernel will be built at the same time and will be available when the kdump kernel is started if a crash happens.
Additional Information
The simplest way to test if all is working is to run the following command:
echo c >/proc/sysrq-trigger
This should start the kdump kernel and save the kernel dump of the production kernel.
Disclaimer
This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.
- Document ID:7018428
- Creation Date: 30-Dec-2016
- Modified Date:03-Mar-2020
-
- SUSE Linux Enterprise Server
For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com