SUSE Support

Here When You Need Us

Exception: 'HealthCheck' object has no attribute 'just' during "deepsea stage run ceph.maintenance.upgrade"

This document (7023280) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Enterprise Storage 5

Situation

The result of "deepsea stage run ceph.maintenance.upgrade" returns the following output:

Ended stage: ceph.maintenance.upgrade succeeded=3/119 failed=2/119 time=1565.5s

Failures summary:

ceph.wait.until.expired.30sec (/srv/salt/ceph/wait/until/expired/30sec):
 <server_NAME>
   wait: Module function wait.just threw an exception. Exception: 'HealthCheck' object has no attribute 'just'
minions.ready (/srv/modules/runners/minions.py):
 Exception occurred in runner minions.ready: Traceback (most recent call last):
   File "/usr/lib/python2.7/site-packages/salt/client/mixins.py", line 395, in _low
     data['return'] = self.functions[fun](*args, **kwargs)
   File "/srv/modules/runners/minions.py", line 82, in ready
     raise RuntimeError("Timeout reached. {} seems to be down.".format(",".join(list(expected - actual))))
 RuntimeError: Timeout reached. <server_NAME> seems to be down.

ceph -s shows that everything is up and running.

Resolution

A Program Temporary Fix (PTF) is available upon request.Please contact SUSE Technical Services for retrieving the package containing the fix.

Cause

A problem with the method usage in the HealthCheck baseclass.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7023280
  • Creation Date: 17-Aug-2018
  • Modified Date:03-Mar-2020
    • SUSE Enterprise Storage

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.