SUSE Support

Here When You Need Us

spacewalk-schema-upgrade fails with "[susemanager-schema-3.1.19] Was not able to find upgrade path in directory [/etc/sysconfig/rhn/schema-upgrade]".

This document (7023370) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Manager 3.1
SUSE Manager 3.2

Situation

While upgrading spacewalk's schema from version 3.1.19 to version 3.2 from SUSE Manager 3.1 to 3.2 the following error occurs :
# spacewalk-schema-upgrade
Schema upgrade: [susemanager-schema-3.1.19-2.30.1] -> [susemanager-schema-3.2.12-3.3.1] Searching for upgrade path to: [susemanager-schema-3.2.12-3.3.1] Searching for upgrade path to: [susemanager-schema-3.2.12] Searching for start path:  [susemanager-schema-3.1.19-2.30.1]
Searching for start path:  [susemanager-schema-3.1.19] Was not able to find upgrade path in directory [/etc/sysconfig/rhn/schema-upgrade].

Resolution

Workaround is to create the missing folder:
# mkdir /etc/sysconfig/rhn/schema-upgrade/susemanager-schema-3.1.19-to-susemanager-schema-3.2.0

This issue is fixed in an upcoming maintenance update (eta : end of the September 2018).

Cause

The following rpm : 

susemanager-schema-3.1.19-to-susemanager-schema-3.2.0  

has a missing folder in it's path :

/etc/sysconfig/rhn/schema-upgrade/

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7023370
  • Creation Date: 24-Sep-2018
  • Modified Date:03-Mar-2020
    • SUSE Manager

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.