SUSE Support

Here When You Need Us

saptune: WARNING saptune.io.go:66: 'noop' is not a valid scheduler for device

This document (7024299) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server for SAP Applications 12 Service Pack 2
SUSE Linux Enterprise Server for SAP Applications 12 Service Pack 3
SUSE Linux Enterprise Server for SAP Applications 12 Service Pack 4
SUSE Linux Enterprise Server for SAP Applications 12 Service Pack 5
SUSE Linux Enterprise Server for SAP Applications 15
SUSE Linux Enterprise Server for SAP Applications 15 Service Pack 1

Situation

The file /var/log/tuned/tuned.log or the output of a saptune command contains a warning like:
 
WARNING  saptune.io.go:66: 'none' is not a valid scheduler for device 'sda', skipping.

Resolution

Please update to a recent version of saptune to get multi scheduler support.

You can delete any customization to mitigate that older versions of saptune could only set one scheduler.
 

Cause

Devices can either support non-multiqueue schedulers (like noop, deadline, cfq) or multiqueue schedulers (like none, mq-deadline, bfq, kyber).
Older version of saptune can set only one scheduler.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7024299
  • Creation Date: 29-Nov-2019
  • Modified Date:31-Jul-2020
    • SUSE Linux Enterprise Server for SAP Applications

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.