SUSE Support

Here When You Need Us

"Multi-user.target start" and "graphical.target" hang

This document (000020259) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server for SAP Applications 15 SP1
Azure Cloud Environment.

Situation

Running “who -r” returns no output.
Running “runlevel” the response is “unknown”. 
Both multi-user.target and graphical.target are in an inactive dead state.
Trying to isolate to multi-user.target hangs until it is manually terminated. 

Resolution

"systemctl list-jobs" shows the following:

JOB UNIT                                                                              TYPE    STATE
259 sapstart.service                                                              start       running
105 multi-user.target                                                             start       waiting
232 systemd-update-utmp-runlevel.service                          start       waiting
-------

sapstart.service is stuck in an endless loop. 
Update the sapstart.service and run "systemctl daemon-reload".

Cause

The sapstart.service called a user customized script which had a "while loop" with no limit on retries causing an endless loop.  

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000020259
  • Creation Date: 26-May-2021
  • Modified Date:11-Jun-2021
    • SUSE Linux Enterprise Server
    • SUSE Linux Enterprise Server for SAP Applications

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.