Failed to upgrade OS from SLES 12 SP5 to SLES 15 SP4 with error message "Connection to registration server failed. Details: undefined method 'resolvable properties' for nil:NilClass"
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Environment
Situation
Connection to registration server failed. Details: undefined method 'resolvable properties' for nil:NilClass
During the upgrade procedure the error message appears after step 4:
https://documentation.suse.com/sles/15-SP4/single-html/SLES-upgrade/#sec-upgrade-offline-yast 4.4 Upgrading SUSE Linux Enterprise Before you upgrade your system, read Chapter 3, Preparing the upgrade first. To perform an automated migration, proceed as follows: Note: SUSE Customer Center and Internet connection If the system you want to upgrade is registered with the SUSE Customer Center, make sure to have an Internet connection during the following procedure. 1. After you have booted (either from an installation medium or the network), select the Upgrade entry on the boot screen. Warning: Wrong choice may lead to data loss Make sure you select Upgrade at this point. If you select Installation by mistake, your data partition will be overwritten with a fresh installation. YaST starts the installation system. 2. On the Welcome screen, choose Language and Keyboard. Proceed with Next. YaST checks your partitions for already installed SUSE Linux Enterprise systems. 3. On the Select for Upgrade screen, select the partition to upgrade and click Next. 4. YaST mounts the selected partition and displays the license agreement for the upgraded product. To continue, accept the license.In step 3, the relevant partition for the upgrade is selected and then in step 4, the upgrade program shows the message "Mounting the partition ...", and when the installer would normally display the license agreement, this step fails with the error message - "Connection to registration server failed. Details: undefined method 'resolvable properties' for nil:NilClass".
Resolution
zypper up
2. Recreate the baseproduct link:
cd /etc/products.d rm /etc/products.d/baseproduct ln -s SLES.prod /etc/products.d/baseproduct
3. Try the OS upgrade again.
Cause
Disclaimer
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- Document ID:000021117
- Creation Date: 28-Jun-2023
- Modified Date:28-Jun-2023
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- SUSE Linux Enterprise Server
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