SUSE Support

Here When You Need Us

Disk inaccessible following SAN outage and recovery

This document (7021114) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server 11
 

Situation

Following a SAN infrastructure failure, where the path to the SAN was interrupted but there were no physical disk failures, some or all of the following messages were seen in logs (such as /var/log/messages), utilities (such as pvscan, vgs, lvs or  nssmu) or in a supportconfig report after the SAN fault was addressed and the Linux/OES server was rebooted:
 
In the following example, /dev/sdx refers to the inaccessible disk.
 
SLES Errors
  • ldm_validate_partition_table(): Disk read failed.
  • sdx: unable to read partition table
  • /dev/sdx: read failed after 0 of 4096 at 0: Input/output error
  • /dev/sdx: read failed after 0 of 4096 at 1099511562240: Input/output error
However, commands such as mount and fdisk show that devices are available but cannot be read.
 
It was seen that two out of four disks were accessible from this server but the other two were not.
 
Rebooting the server did not help.

Resolution

Rebooting the SAN node that the server was connected to resolved the problem.  

Cause

The SAN Support Team were not able to identify why this should resolve the issue.  It may have been a symptom of the original fault that caused the SAN to fail in the first place. 

Additional Information

As a troubleshooting step, the following command was used to determine if the disk was readable at a block level:
 
dd if=/dev/sdx of=/tmp/sdx.out bs=1024 count=5
 
This would fail attempting to read a few blocks of the disk.
 
The dd command does a block-level read/copy of the disk and is therefore independent of any filesystem on the disk; in other words, even if the filesystem were irreparably corrupt, dd would still be able to read and copy that data (including any corruption).  As other disks on the same server, which use the same driver, could be successfully read, it suggested that the driver was functioning correctly.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7021114
  • Creation Date: 20-Jul-2017
  • Modified Date:18-Feb-2021
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.