SUSE Support

Here When You Need Us

vPMEM memory backed namespaces configured as a dump target for kdump/fadump takes a long time to save dump files

This document (7024330) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 15 Service Pack 1 (ppc64le)
Minimum kernel version kernel-default-4.12.14-197.21.1.ppc64le
With libndctl6-64.1-3.3.1.ppc64le.rpm installed

IBM POWER9 (ppc64le)
Virtual persistent memory (vPMEM) with PowerVM

Situation

Booting of the capture kernel takes a very long time.

Resolution

Workaround:

It is advisable to not use vPMEM namespaces as dump target for kdump/fadump.

Cause

During capture kernel (kdump/fadump) boot, the papr_scm module is forced to un-map and re-map the memory backed by vPMEM and to re-add it to its linear map. This requires expensive HCalls to the PHYP hypervisor and total time taken is proportional to the size of vPMEM available to the PowerVM LPAR. Net effect of this is that it can slow down the boot of the capture kernel considerably.

Additional Information

If a user still prefers to use vPMEM memory as a dump target for kdump or fadump, the "papr_scm.ko" module must be explicitly included in the initrd. To achieve this create the file /etc/dracut.conf.d/99-pmem-workaround.conf with the below content:

add_drivers+="nd_pmem nd_btt libnvdimm papr_scm"


And then rebuilt the initrd:

  # touch /etc/sysconfig/kdump
  # systemctl restart kdump.service

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7024330
  • Creation Date: 09-Dec-2019
  • Modified Date:03-Mar-2020
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.