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Clients report pending updates in web-UI even when they are fully patched

This document (000019939) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Manager 4.1 Server
SUSE Manager 4.2 Server

Situation

It can happen that registered clients in SUSE Manager Server web-UI report pending updates in spite of the fact that they are fully patched.

Resolution

Check whether following messages have appeared recently in /var/log/rhn/rhn_taskomatic_daemon.log
2021-03-30 06:11:00,074 [DefaultQuartzScheduler_Worker-6] INFO  com.redhat.rhn.taskomatic.task.ErrataCacheTask - In the queue: 2
2021-03-30 08:52:00,173 [DefaultQuartzScheduler_Worker-11] INFO  com.redhat.rhn.taskomatic.task.ErrataCacheTask - In the queue: 1
When you can not see any up-to-date message, restart taskomatic service:
suma_system:~ # systemctl restart taskomatic.service
After a restart of the service in /var/log/rhn/rhn_taskomatic_daemon.log every minute a message like this will appear:
INFO  com.redhat.rhn.taskomatic.task.ErrataCacheTask - In the queue: 1065
The number should decrease over time. At some point in time the Task Queue should be empty and no message is printed anymore.

Cause

In some situation (e.g. update of SUSE Manager) it can happen that the internal worker dies and it needs to be restarted.

Additional Information

If this TID did not help, please also check the TID 000020572 (SUMA Client Patch Status (WebUI and CLI) is Not in Sync) about regenerating the YUM cache.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000019939
  • Creation Date: 07-Apr-2021
  • Modified Date:24-Mar-2022
    • SUSE Manager Server
    • SUSE Manager

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