SUSE Support

Here When You Need Us

SLES12 SP3 - squid dumping core

This document (7023183) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 12 Service Pack 3 (SLES 12 SP3)

Situation

The squid proxy server may core dump with messages logged like the following:

2018-07-13T08:15:22.970113+02:00 xxxxxxxx systemd-coredump[22215]: Process 21979 (squid) of user 31 dumped core.
2018-07-13T08:27:05.128523+02:00 xxxxxxxx squid[22217]: assertion failed: comm.cc:1595: "isOpen(fd) && !commHasHalfClosedMonitor(fd)"
2018-07-13T08:27:08.377838+02:00 xxxxxxxx squid[24161]: Starting Squid Cache version 3.5.21 for x86_64-suse-linux-gnu...
2018-07-13T08:27:08.378024+02:00 xxxxxxxx squid[24161]: Service Name: squid

Resolution

There is no real fix available yet. However, you can work around this problem as described in the 'Cause' section.

Cause

The core dump may be caused by the following entry in the squid.conf

half_closed_clients on

to work around this problem you may set this to

half_closed_clients off

It is recommended to keep this option off.

Additional Information

This is a long outstanding bug. Even in the upstream version of squid this bug still exists.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7023183
  • Creation Date: 17-Jul-2018
  • Modified Date:03-Mar-2020
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.