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General troubleshooting for client SP migration within SUSE Manager.

This document (7023296) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Manager 4.3
SUSE Manager 5.0


Situation

A client registered to SUSE Manager needs to get updated to the following SP.

Resolution

The following points should be checked, if possible, before the migration:
 
- All products/extensions/add-ons should be mirrored in the destination SP. Example: Webscripting extension is used for SLES 12 SP2, the extension should already be mirrored for SP3. Otherwise, no migration will be even suggested and a message with "no migration available" will be shown.
 
NOTE: To see missing channels in the grayed out (not selectable) Service-Pack, move the mouse-over the grayed area and wait for the tooltip to come up with more information.

- The existence of foreign packages (non-SUSE) should be checked, usually coming from foreign repositories, or from manually installed RPMs. This won't prevent the migration to start, but might make it failed due to missing dependencies. This problem can be easily and previously checked in the rpm.txt file of the supportconfig of the client, or by running:
 
rpm -qa --queryformat "%-35{NAME} %-35{DISTRIBUTION} %{VERSION}-%{RELEASE}\n" | sort -k 1,2 -t " " -i | less
 
- Kernel multi-version should be disabled.
Further information can be found here: https://www.suse.com/support/kb/doc.php?id=7015547
 
Once those basic checks are performed, should further problems still exist, opening a case with Support would be expected. However, in cases where the migration failed at some point of the process, running "zypper dup" in the client will usually show the error in a verbose mode, as the client usually stays registered against the new SP channels.

Cause

The cause can be different and are explained in the resolution section. Most of the times, it is either missing channels in the target SP or dependencies problems (either foreign packages or a multi-version kernel).

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7023296
  • Creation Date: 23-Aug-2018
  • Modified Date:18-Oct-2024
    • SUSE Manager

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