SUSE Support

Here When You Need Us

Time zone abbreviations missing for multiple time zones after update to timezone-2017a or later

This document (7023384) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 11 Service Pack 3 (SLES 11 SP3)
SUSE Linux Enterprise Server 11 Service Pack 4 (SLES 11 SP4)
SUSE Linux Enterprise Server 12 (SLES 12)
SUSE Linux Enterprise Server 12 Service Pack 1 (SLES 12 SP1)
SUSE Linux Enterprise Server 12 Service Pack 2 (SLES 12 SP2)

Situation

Several time zones that used to be represented by an abbreviation are now represented by an offset to UTC, for example:
$ TZ="Asia/Singapore" date
Thu Sep 27 21:02:16 +08 2018
$
this was formerly:
$ TZ="Asia/Singapore" date
Thu Sep 27 21:02:16 SGT 2018
$

Resolution


Cause

To avoid conflicts between informal and newly introduced official abbreviations, the IANA timezone data maintainers removed all time zone abbreviations that are not backed by laws or governmental and standardization bodies, starting with the 2017a release of tz code and data. This is documented in the release notes of the 2017a IANA tz code and data release.

Additional Information


Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7023384
  • Creation Date: 27-Sep-2018
  • Modified Date:03-Mar-2020
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.