SUSE Support

Here When You Need Us

Object Storage Daemon service is shown as not running / unknown

This document (000020319) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Enterprise Storage 7

Situation

After upgrading from SES 6 to SES 7, although all OSDs are up and running ("ceph orch ps --daemon-type osd" shows all OSD daemons as "running") the "ceph orch ls" command however shows the OSD service similar to the following example, excerpt:
 
NAME RUNNING REFRESHED AGE PLACEMENT IMAGE NAME IMAGE ID
...
osd.default 0/8 - - osd_node1;osd_node2;osd_node3;... <unknown> <unknown>
...

Resolution

The issue is cosmetic since all OSDs are up and running.

Cause

The "osdspec_affinity" metadata is not present for existing OSDs when upgraded from SES 6.

Status

Reported to Engineering

Additional Information

Although this is cosmetic, the situation is not ideal, currently the recommended way to resolve this cosmetic issue is to, one at a time, re-deploy each of the OSD hosts and its OSDs. This will allow the proper metadata to be set during creation since the OSD host and its OSDs are now created "new" on SES 7.

Alternatively, SUSE is working on a solution to be able to resolve this issue without having to re-remove and re-deploy the host and OSDs. For details contact SUSE Support.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000020319
  • Creation Date: 05-Jul-2021
  • Modified Date:05-Jul-2021
    • SUSE Enterprise Storage

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.