SUSE Support

Here When You Need Us

Configuring DASD with YaST on zSeries - "Execution of command "[["/sbin/mkinitrd"]]" failed"

This document (000021387) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 15 SP5 

Situation

When configuring DASD on IBM zSeries with YaST a pop-up with the following error appears:
Error
Execution of command "[["/sbin/mkinitrd"]]" failed. Exit
code: 127 Error output: No such file or directory - 
/sbin/mkinitrd

In /var/log/YaST2/y2log a similar error will be shown:
2024-03-05 19:14:35 <1> <hostname>(7785) [Ruby] lib/cheetah.rb(record_commands):160 Executing "/sbin/fdasd -p /dev/dasdb".
...
2024-03-05 19:14:37 <1> <hostname>(7785) [Ruby] lib/cheetah.rb(record_commands):160 Executing "/sbin/mkinitrd".
2024-03-05 19:14:37 <3> <hostname>(7785) [Ruby] lib/cheetah.rb(log_stream_line):208 Error output: No such file or directory - /sbin/mkinitrd
2024-03-05 19:14:37 <3> <hostname>(7785) [Ruby] lib/cheetah.rb(record_status):180 Status: 127
2024-03-05 19:14:37 <3> <hostname>(7785) [Ruby] yast2/execute.rb(rescue in popup_error):235 Execution of command "[["/sbin/mkinitrd"]]" failed.
Exit code: 127
Error output: No such file or directory - /sbin/mkinitrd

Resolution

The yast2-s390 update (yast2-s390-4.5.4-150500.3.6.3) with the patch replacing 'mkinitrd' with 'dracut' was released April/2024.
 

Cause

One of the source codes still contains a call to /sbin/mkinitrd instead to its replacement, dracut.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000021387
  • Creation Date: 05-Mar-2024
  • Modified Date:04-Apr-2024
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.