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CUPS printer in a stopped state

This document (7014022) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 11

Situation

CUPS printer is in a stopped state.  End users cannot print to that printer.

Resolution

Change the CUPS Error Policy to retry-job.  There are 3 method to choose from to accomplish this.

Method 1: Per printer, command line
Enter this command at a terminal session while logged in as root:
Syntax:
/usr/sbin/lpadmin -p <NameOfPrinter> -o printer-error-policy=retry-job
Note: replace <NameOfPrinter> with the name of the CUPS printer experiencing the problem.
Example:
/usr/sbin/lpadmin -p HPLJ4050-secretaryDesk -o printer-error-policy=retry-job
Method 2: Per printer, printers.conf
To make this change on a per printer basis through the printers.conf,
  • Open the /etc/cups/printers.conf
  • Find the printer you wish to modify.
    • <Printer "PrinterName">
      • The "PrinterName" will be the name of the CUPS printer.  The quotes will not be in the printers.conf.
  • Change the ErrorPolicy entry for that printer from stop-printer to retry-job
  • Save the change
  • Restart CUPS
    • rccups restart

Method 3: Globally, cupds.conf
To make this change for all printers on the Linux system,
  • Open the /etc/cups/cupsd.conf
  • Do a find for ErrorPolicy
    • If you find it, change the entry from stop-printer to retry-job
    • If you do not find that entry, add the following at the end of the file:
      • ErrorPolicy retry-job
  • Save the change
  • Restart CUPS
    • rccups restart

Cause

CUPS introduced an Error Policy which puts the CUPS printer into a stopped state when physical printers experiences an error, such as, Paper Jam, Out of Paper, Paper Tray Open, etc.  The CUPS printer does not change to an idle or ready state even after the physical problem is resolved.  Unless the steps above are taken, the administrator must go to YaST or the CUPS Web Administration to change the printer out of the stopped state.

Additional Information


Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7014022
  • Creation Date: 29-Oct-2013
  • Modified Date:03-Mar-2020
    • SUSE Linux Enterprise Server

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