SUSE Support

Here When You Need Us

Renaming a second samba shared printer reverts back to the first

This document (7015810) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 10
SUSE Linux Enterprise Server 11
SUSE Linux Enterprise Server 12
Samba printer queues

Situation

When sharing print queues through samba, it is possible to upload printer drivers that are automatically installed with the printers. When a printer driver is assigned to a samba print queue, that queue is renamed to the name of the driver. An administrator can then re-name the printer back to it's original name. If the administrator repeats this process and goes to re-name the second printer, the dialog window that opens to rename the second printer is actually that of the first.

Resolution

The issue can be avoided by utilizing the:

force printername = Yes

option in the /etc/samba/smb.conf

This option forces the printer's printername to match the sharename defined in the smb.conf

As such, the printer names will be deployed to workstations as defined on the samba server.



Alternatively, the samba update to samba-3.6.3-0.58.1 released in May 2015 includes the patch to purge the printer name cache.

Cause

Stale entries in the printer name cache are not purged when a printer is renamed.
If a printer takes the name of a stale (previously renamed) entry in the cache, then the server retrieves the incorrect printer information from the registry and returns it to the client.

Additional Information

Additional reading about this option can be found in the man page for smb.conf

https://www.samba.org/samba/docs/man/manpages-3/smb.conf.5.html

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7015810
  • Creation Date: 21-Oct-2014
  • Modified Date:03-Mar-2020
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.