SUSE Support

Here When You Need Us

How to trigger kdump of a hanging KVM guest

This document (7018497) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 12 Service Pack 1 (SLES 12 SP1)
SUSE Linux Enterprise Server 12 Service Pack 2 (SLES 12 SP2)
SUSE Linux Enterprise Server 11 Service Pack 4 (SLES 11 SP4)

Situation

A KVM based SLE virtual machine was configured for kdump (for setting up kdump within the guest see TID 3374462 - Configure kernel core dump capture), usually the dump is created inside the guest, but in rare circumstances the dump was not being triggered and the guest "hangs" without being able to log in - neither ssh nor via console.

Resolution

As virsh is capable to generate a dump of a guest via libvirt it is possibe to trigger the dump by  invoking


virsh dump <domainid> <outputfilename> [<options>]


e.g. virsh dump sles12sp2-testserver /data/corefile.output --memory-only --reset

This would create a plain CPU register and memory dump of the guest named "sles12-sp2-testserver" being written to /data/corefile.output. After the dump has been written, the guest will be reset for being able to pickup regular operations after a reboot.


Cause

In this particular case the guest hang as the underlying storage devices for the guest disk images on the KVM host lost connections to the fabric. This is only one case in which a dump would not be triggered.

Additional Information

For uploading the dumpfile please follow the steps as described on https://www.suse.com/support/kb/doc?id=7010056

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7018497
  • Creation Date: 19-Jan-2017
  • Modified Date:03-Mar-2020
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.