SUSE Support

Here When You Need Us

Sync of Red Hat channels fails with "Cannot access repository. Maybe repository GPG keys are not imported"

This document (000020297) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Manager 4.1 Server

Situation

Sync of Red Hat channels into SUSE Manager Server fails, when trying to run manually
/usr/bin/spacewalk-repo-sync --channel rhel7-pool-x86_64 --type yum
with following error message:
15:50:18 ======================================
15:50:18 | Channel: rhel7-pool-x86_64
15:50:18 ======================================
15:50:18 Sync of channel started.
Retrieving repository 'rhel7-pool-x86_64' metadata ........................................................................................................................[error]
Repository 'rhel7-pool-x86_64' is invalid.
[rhel7-pool-x86_64|http://localhost/pub/repositories/empty/] Valid metadata not found at specified URL
History:
 - [|] Error trying to read from 'http://localhost/pub/repositories/empty/'
 - Permission to access 'http://localhost/pub/repositories/empty/content' denied.

Please check if the URIs defined for this repository are pointing to a valid repository.
Skipping repository 'rhel7-pool-x86_64' because of the above error.
Could not refresh the repositories because of errors.
15:50:20 RepoMDError: Cannot access repository. Maybe repository GPG keys are not imported
15:50:20 Total time: 0:00:01

 

Resolution

In case that such error occurs this is an issue with the certificates (which needs to be addressed to Red Hat) which keep SUSE Manager Server from talking to Red Hat CDN.
 

Cause

It is an upstream issue with Red Hat reissuing the certificates to the customers. This invalidated the previous
certificates used.  If it continues to happen it is recommended to contact Red Hat and discuss why the certificates are getting invalidated.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000020297
  • Creation Date: 25-Jun-2021
  • Modified Date:25-Jun-2021
    • SUSE Manager Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.