system failed to reboot - ncurses6 package
This document (000020582) is provided subject to the disclaimer at the end of this document.
Environment
SUSE Linux Enterprise High Availability Extension 15 and all Service Packs
SUSE Linux Enterprise Server 15 and all Service Packs
Situation
An interruption occurred during the patching of the system, and later on; the system failed to boot normally. During the booting; there were some "timed out waiting for device" errors on data file systems, resulting in a boot failure.
From rescue mode, the following error was observed:
tty1:rescue: # chroot /mnt /bin/bash: error while loading shared libraries: libtinfo.so.6: cannot open shared object file: No such file or directory tty1:rescue: # rpm -qf --root /mnt /lib64/libtinfo.so.6 libncurses6-6.1-5.9.1.x86_64In a separate case, the server booted fine, but got the following error when attempting to login:
-bash: error while loading shared libraries: libtinfo.so.6: cannot open shared object file: No such file or directorySituation Two
Following a power outage, a separate server hung at boot time with the following errors:
[FAILED] Failed to start Wait for udev To Complete Device Initialization. lvm[533]: segfault at 8 ip 00007fe0a08a4f8e sp 00007fff29828570 error 4 in ld-2.31.so [*** ] A start job is running for LVM direct activation of logical volumes (15min / no limit)When the attempting to chroot that the installed system from rescue mode, the following was observed:
tty1:rescue: # chroot /mnt Segmentation fault (core dumped)
Resolution
1. Chroot the installed system in rescue mode. (Refer to TID000018770: How to Chroot in Rescue Mode)
2. Mount the latest installation media for your service pack or copy the libncurses6 package to a drive that can be mounted on the server in rescue mode.
3. Install the package
tty1:rescue: # rpm -ihv –force --root /mnt /path/to/libncurses6*.rpm4. Exit rescue mode and unmount the file systems.
# exit # umount /mnt/* # umount /mntIf umount /mnt shows busy, then do
# exit # umount -l /mnt5. Reboot the system normally to confirm it boots properly.
# reboot
Cause
Disclaimer
This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.
- Document ID:000020582
- Creation Date: 10-Feb-2022
- Modified Date:15-Feb-2022
-
- SUSE Linux Enterprise High Availability Extension
- SUSE Linux Enterprise Server
- SUSE Linux Enterprise Server for SAP Applications
For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com