SUSE Support

Here When You Need Us

Calico-Node Error on Ubuntu20.04 calico_tmp_A: Could not generate persistent MAC: No data available

This document (000021561) is provided subject to the disclaimer at the end of this document.

Environment

Rancher
RKE
RKE2
Calico version: 3.27.3 and 3.28.0
Ubuntu: 20.4, kernel version from 5.4.0-182-generic 

Situation

Issue: The newly installed version of calico evoked the following error logs (syslog,systemd-udevd)

Operating system syslog/messages; error

Sep 11 12:22:54 K8s-RKE2-SIN12-W1 systemd-udevd[21836]: calico_tmp_A: Failed to get link config: No such device
Sep 11 12:22:54 K8s-RKE2-SIN12-W1 systemd-udevd[21813]: ethtool: could not get ethtool features for calico_tmp_B
Sep 11 12:22:54 K8s-RKE2-SIN12-W1 systemd-udevd[21813]: Could not set offload features of calico_tmp_B: No such device
Sep 11 12:22:55 K8s-RKE2-SIN12-W1 systemd-udevd[21836]: calico_tmp_A: Failed to get link config: No such device
Sep 11 12:22:55 K8s-RKE2-SIN12-W1 systemd-udevd[21813]: ethtool: could not get ethtool features for calico_tmp_B
Sep 11 12:22:55 K8s-RKE2-SIN12-W1 systemd-udevd[21813]: Could not set offload features of calico_tmp_B: No such device

Calico-node daemonset logs; error 
2024-09-11 05:54:40.201 [INFO][62] felix/int_dataplane.go 2011: Received interface update msg=&intdataplane.ifaceStateUpdate{Name:"calico_tmp_A", State:"", Index:271742} 2024-09-11 05:54:40.248 [INFO][62] felix/xdp_state.go 200:
Retrying after an XDP update failure... 2024-09-11 05:54:40.288 [INFO][62] felix/xdp_state.go 200:
Retrying after an XDP update failure... 2024-09-11 05:54:40.298 [INFO][62] felix/int_dataplane.go 1387: Linux interface state changed. ifIndex=271757 ifaceName="calico_tmp_
 

Resolution

A known issue, both Calico versions 2.27.3 and 2.28.0 are impacted by the same issue,

 Upgrade the Ubuntu Linux kernel version (kernel version from 5.4.0-182-generic to 5.15.0-107-generic)
 
 

Cause

A known issue, both calico 2.27.3 and 2.28.0 also are affected by this. 

Status

Top Issue

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000021561
  • Creation Date: 13-Sep-2024
  • Modified Date:27-Sep-2024
    • SUSE Rancher

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.