SUSE Support

Here When You Need Us

spacewalk-schema-upgrade fails with "relation "suseimageinfopackage" does not exist"

This document (7022839) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Manager 3.1

Situation

When applying latest schema upgrades to the SUSE Manager database, the process fails with messages similar to:
[...]
Executing spacewalk-sql, the log is in [/var/log/spacewalk/schema-upgrade/schema-from-20180410-174141-to-susemanager-schema-3.0.25.log].
(1/7) apply upgrade [susemanager-schema-3.0.22-to-susemanager-schema-3.0.23/001-may_take_long-fix-rhn_pe_v_r_e_uq.sql.postgresql]
Upgrade failed, please see log [/var/log/spacewalk/schema-upgrade/schema-from-20180410-174141-to-susemanager-schema-3.0.25.log].

While looking at /var/log/spacewalk/schema-upgrade/schema-from-20180410-174141-to-susemanager-schema-3.0.25.log the following error is found:
[...]
DROP INDEX
DROP INDEX
CREATE FUNCTION
DROP TRIGGER
psql:<stdin>:88: ERROR:  relation "suseimageinfopackage" does not exist
LINE 1: update suseImageInfoPackage set evr_id = original.id where e...
               ^
QUERY:  update suseImageInfoPackage set evr_id = original.id where evr_id = duplicate.id
CONTEXT:  PL/pgSQL function fix_rhn_pe_v_r_e_uq() line 70 at SQL statement 

Resolution

Fixed as of susemanager-schema >= 3.1.16-2.20.1.

https://download.suse.com/Download?buildid=giNV9QlhhSE~

- Remove update of not existing table (bsc#1087131)

Cause

A problem in the schema update trying to update a table that does no longer exist.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7022839
  • Creation Date: 11-Apr-2018
  • Modified Date:03-Mar-2020
    • SUSE Manager

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.