SUSE Support

Here When You Need Us

mdadm exists with segmentation fault on array assembly

This document (7023260) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 11 Service Pack 4 (SLES 11 SP4)
SUSE Linux Enterprise Server 12 Service Pack 2 (SLES 12 SP2)
SUSE Linux Enterprise Server 12 Service Pack 3 (SLES 12 SP3)

Situation

When assembling a softRAID using mdadm, a core dump is experienced:

# mdadm -A -c /lfs/xen/config/ltdbmri0011vm/mdadm.conf /dev/md/ltdbmri0011vm
Segmentation fault (core dumped)


This issue may be observed in different environments (XEN based VMs, physical server).

Resolution

A Program Temporary Fix for SLES 11 SP4 has been made available. Please contact SUSE Technical Service for a copy until the regular maintenance update is available.

SLES 12 SP2 is entered Long Term Service Support (LTSS) on 2018-March-31, the fix will be made available via the LTSS update channels.

For SLES 12 SP3 please update to mdadm-4.0-6.16.1 or later to address this issue.

Cause

A negative return code in the variable for the best devices handling.

Additional Information

(gdb) bt
#0  0x000000000041a9e3 in Assemble (st=0x6be780, mddev=0x7ffdadc3a822 "/dev/md1001", ident=0x698690, devlist=0x6ded00, c=0x7ffdadc38b60) at Assemble.c:1679
#1  0x0000000000405739 in main (argc=<optimized out>, argv=0x7ffdadc390e8) at mdadm.c:1404

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7023260
  • Creation Date: 13-Aug-2018
  • Modified Date:03-Mar-2020
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.