SUSE Support

Here When You Need Us

default-resource-stickiness cluster property is deprecated

This document (7023809) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise High Availability Extension 12

Situation

After an update during normal cluster operations with

  crm

shell or via scripts calling the crm shell there might be errors like

 gitanes:~ # crm configure <some_command>
 ERROR: Warnings found during check: config may not be valid
 Do you still want to commit (y/n)? y

which will break scripts and might puzzle Administrators. While the normal cluster operations are not affected.

Resolution

Invoking

 crm verify

will show the culprit and the solution as

 warning: unpack_config:        Support for 'default-resource-stickiness' cluster property is deprecated and will be removed in a future release (use resource-stickiness in rsc_defaults instead)

the easiest solution for this issue is to set the proper parameter with

 crm configure rsc_defaults resource-stickiness=1000

and then to remove via

 crm configure edit

the old deprecated one "default-resource-stickiness".

Please keep in mind that the above given 1000 as a value is only an example and should be adjusted to the old value of default-resource-stickiness.

No stop or restart of any cluster element is necessary for this adjustment.

Cause

The property value

   default-resource-stickiness

is deprecated.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7023809
  • Creation Date: 08-Apr-2019
  • Modified Date:03-Mar-2020
    • SUSE Linux Enterprise High Availability Extension

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.