SUSE Support

Here When You Need Us

Paravirtualized virtual machines not being able to perform autoinstallations in provisioning tab

This document (000019846) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Manager Server 4.1

Situation

The autoinstallation function is not even shown for some clients, which happen to be paravirtualized clients. As this is the default mode for some cloud instances such as Azure, customers might think the problem is cloud specific, however it is a general issue with any paravirtualized server, no matter whether it is a cloud instance or not and not even being important the vendor providing the cloud instance.

Resolution

A patch was released in order to address this problem. The patch was made available for SUSE Manager 4.1.5 and higher.
The patch will not fix the issue for existing clients, rather only for new ones. In order to resolve the problem in existing SUSE Manager clients, a small script will need to be run. This will be explained in detail in the "additional information" section.

Cause

"VirtualPC" is an unknown type of virtualization to SUSE Manager. It was added with the patch.

Status

Reported to Engineering

Additional Information

Once the patch has been applied (either as a maintenance update when released, or as a PTF), and the services have been restarted, a small SQL script should be run in the SUSE Manager in order to update some values in a database. A file should be created, it will be named 003-add-virtual-instance-type.sql (although the name is not relevant). It should contain this code:
INSERT INTO rhnVirtualInstanceType (id, name, label)
  SELECT sequence_nextval('rhn_vit_id_seq'), 'VirtualPC', 'virtualpc'
  FROM dual
  WHERE NOT EXISTS(select 1 from rhnVirtualInstanceType WHERE label='virtualpc');
It can be applied by simply running:
spacewalk-sql 003-add-virtual-instance-type.sql
Lastly, a hardware refresh will be needed on each of the previously existing para-virtualized servers (in SUSE Manager web-UI, after selecting the system, navigating to "Details", "Hardware" and then clicking on "Schedule Hardware Refresh").

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000019846
  • Creation Date: 25-Jan-2021
  • Modified Date:16-Feb-2021
    • SUSE Manager Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.