SUSE Support

Here When You Need Us

Offline Upgrade from SLES12 SP5 to SLES15 SP5 Fails with Undefined Method

This document (000021282) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server for SAP Applications 12
SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server for SAP Applications 15

Situation

Trying to offline upgrade from SLES12 SP5 to SLES15 SP5, but getting the following message during the upgrade.
 
Internal error. Please report a bug report with logs.
Run save_y2logs to get complete logs.

Details: undefined method `[]' for false:FalseClass
Caller: /mounts/mp_0001/usr/share/YaST2/lib/installation/proposal_runner.rb:487:in `block in make_proposal'

Resolution

Regenerate /boot/grub2/grub.cfg with default locales before starting the upgrade. For example,
# LANG=en_US.utf8 LC_ALL=en_US.utf8 grub2-mkconfig --output=/boot/grub2/grub.cfg
# file /boot/grub2/grub.cfg
/boot/grub2/grub.cfg: ASCII text

Cause

The root of issue is /boot/grub2/grub.cfg contains strings localized without UTF-8. In SLE-15 YaST/Installer supports only UTF-8 based locales. For example
# file /boot/grub2/grub.cfg
/boot/grub2/grub.cfg: ISO-8859 text

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000021282
  • Creation Date: 23-Nov-2023
  • Modified Date:21-Dec-2023
    • SUSE Linux Enterprise Server
    • SUSE Linux Enterprise Server for SAP Applications

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.