VNC connection fails with "Invalid Protocol"
This document (7000039) is provided subject to the disclaimer at the end of this document.
Environment
SUSE Linux Enterprise Desktop 11 (SLED 11)
Remote Administration (VNC) enabled.
VNC client or browser being used to establish the VNC connection.
Situation
The error may go away after some time (15-30 minutes) or a reboot may clear the error.
Resolution
rcxdm stop
rm /tmp/.X*-lock
rm /tmp/.X11-unix/X*
rcxdm start
Test the VNC connection to see if the problem is resolved.
Cause
The /tmp/.X11-unix/X* are the socket files created by the X server when it starts up for the specific display number.
When an instance of the X server is terminated properly it will remove these files, indicating that the display is no longer in use. If for some reason the X server is not terminated properly then these files can be left behind and eventually cause the X server to report that there are no displays available.
The message reported by the VNC client does not give any indication of the problem. The only place to see the display error is in a packet trace.
Additional Information
Disclaimer
This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.
- Document ID:7000039
- Creation Date: 21-Oct-2013
- Modified Date:03-Mar-2020
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- SUSE Linux Enterprise Desktop
- SUSE Linux Enterprise Server
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