SUSE Support

Here When You Need Us

Installation fails when attempting to remove LVM thin pool, manual repair required.

This document (7024193) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 11 Service Pack 4 (SLES 11 SP4)
IBM Power (ppc64le)


Situation

When attempting to install SUSE Linux Enterprise Server on an LPAR (Logical Partition) that previously had another Linux distribution installed, the installation fails with:

System error code was: -1007

/sbin/vgremove -f '<some_vg>'
  Check of thin pool <some_vg>/<lv> failed (status:1). Manual repair required.

Resolution

Remove any LVM volumes not created by SLE 11 SP4 from any disk that will be used for system or data during installation prior to starting the SLE 11 SP4 installation.

Cause

Since SLE 11 SP4 has been released the development of LVM continued providing new features requiring new on-disk LVM volume formats. SLE 11 is not compatible with all new LVM formats and may fail to install when such new format is used on disk to which SLE 11 is to be installed.

Additional Information


Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7024193
  • Creation Date: 21-Oct-2019
  • Modified Date:03-Mar-2020
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.