SUSE Support

Here When You Need Us

LPD Print Queue error Too many active jobs

This document (000020645) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server for SAP Applications 15 SP1 x86_64

Situation

A CUPS print queue reported  (logs can be found on the  /var/log/cups/error_log) the following error message many times: 
/usr/bin/lpr: Too many active jobs.

Resolution

Add the following line to the "/etc/cups/cupsd.conf" file.
MaxJobs 0

Cause

If the CUPS received more than 500 jobs simultaneously (the default limit), then the above errors will be logged, and the printing will be stopped. To avoid this situation, and if usually submit more than hundreds of jobs, Then it is advised to modify the limit. 

To change the limit to a new value or to disable the limit, then, add a new line in the configuration file "/etc/cups/cupsd.conf" for the "MaxJob" parameter like the following:
MaxJobs number

Example (1): To have a new limit of 2000 jobs at a time.
MaxJobs 2000

Example (2): To disable the limit.
MaxJobs 0


 

Additional Information

It is advisable to monitor the system using the "lpstat" or similar tools. You can also access the CUPS from the browser https://localhost:631 for more insight, ("cups-browsed.service" needs to be active), and check the logs from the browser http://localhost:631/admin/log/error_log?

For more information about the CUPS print queue, kindly, check the following link:
https://documentation.suse.com/sles/15-SP1/html/SLES-all/cha-print.html#sec-print-method

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000020645
  • Creation Date: 27-Apr-2022
  • Modified Date:18-May-2022
    • SUSE Linux Enterprise Server
    • SUSE Linux Enterprise Server for SAP Applications

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.