Upstream information

CVE-2021-44269 at MITRE

Description

An out of bounds read was found in Wavpack 5.4.0 in processing *.WAV files. This issue triggered in function WavpackPackSamples of file src/pack_utils.c, tainted variable cnt is too large, that makes pointer sptr read beyond heap bound.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.5 5.5
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
Access Vector Local Local
Access Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact None High
Integrity Impact None None
Availability Impact High None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1197020 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Image SLES15-SP3-EC2-HVM
Image SLES15-SP3-SAP
Image SLES15-SP3-SAP-Azure
Image SLES15-SP3-SAP-EC2-HVM
Image SLES15-SP3-SAP-GCE
Image SLES15-SP3-SAPCAL-Azure
Image SLES15-SP3-SAPCAL-EC2-HVM
Image SLES15-SP3-SAPCAL-GCE
Image SLES15-SP4-SAP
Image SLES15-SP4-SAP-Azure
Image SLES15-SP4-SAP-EC2
Image SLES15-SP4-SAP-GCE
Image SLES15-SP4-SAPCAL
Image SLES15-SP4-SAPCAL-Azure
Image SLES15-SP4-SAPCAL-EC2
Image SLES15-SP4-SAPCAL-GCE
  • libwavpack1 >= 5.4.0-4.12.1
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Linux Enterprise Storage 7.1
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • libwavpack1 >= 5.4.0-4.12.1
  • wavpack >= 5.4.0-4.12.1
  • wavpack-devel >= 5.4.0-4.12.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2022-954
SUSE-SLE-Module-Desktop-Applications-15-SP3-2022-954
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • libwavpack1 >= 5.4.0-4.12.1
  • wavpack >= 5.4.0-4.12.1
  • wavpack-devel >= 5.4.0-4.12.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA libwavpack1-5.4.0-4.12.1
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 GA wavpack-5.4.0-4.12.1
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • libwavpack1 >= 5.4.0-4.12.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2022-954
SUSE Linux Enterprise Module for Basesystem 15 SP4
  • libwavpack1 >= 5.4.0-4.12.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA libwavpack1-5.4.0-4.12.1
SUSE Linux Enterprise Module for Desktop Applications 15 SP3
  • wavpack >= 5.4.0-4.12.1
  • wavpack-devel >= 5.4.0-4.12.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP3-2022-954
SUSE Linux Enterprise Module for Desktop Applications 15 SP4
  • wavpack >= 5.4.0-4.12.1
  • wavpack-devel >= 5.4.0-4.12.1
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 GA wavpack-5.4.0-4.12.1
SUSE Linux Enterprise Real Time 15 SP2
  • libwavpack1 >= 5.4.0-4.12.1
  • wavpack >= 5.4.0-4.12.1
  • wavpack-devel >= 5.4.0-4.12.1
Patchnames:
SUSE-SLE-Product-RT-15-SP2-2022-954
openSUSE Leap 15.3
  • libwavpack1 >= 5.4.0-4.12.1
  • libwavpack1-32bit >= 5.4.0-4.12.1
  • wavpack >= 5.4.0-4.12.1
  • wavpack-devel >= 5.4.0-4.12.1
Patchnames:
openSUSE-SLE-15.3-2022-954
openSUSE Leap 15.4
  • libwavpack1 >= 5.4.0-4.12.1
Patchnames:
openSUSE Leap 15.4 GA libwavpack1-5.4.0-4.12.1
openSUSE Tumbleweed
  • libwavpack1 >= 5.4.0-2.1
  • libwavpack1-32bit >= 5.4.0-2.1
  • wavpack >= 5.4.0-2.1
  • wavpack-devel >= 5.4.0-2.1
Patchnames:
openSUSE Tumbleweed GA libwavpack1-32bit-5.4.0-2.1


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 wavpack Not affected
SUSE CaaS Platform 4.0 wavpack In progress
SUSE Enterprise Storage 6 wavpack In progress
SUSE Enterprise Storage 7 wavpack In progress
SUSE Linux Enterprise Desktop 15 SP3 wavpack Released
SUSE Linux Enterprise Desktop 15 SP4 wavpack Released
SUSE Linux Enterprise High Performance Computing 12 SP5 wavpack Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS wavpack In progress
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS wavpack In progress
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS wavpack In progress
SUSE Linux Enterprise High Performance Computing 15 SP2 ESPOS wavpack In progress
SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS wavpack In progress
SUSE Linux Enterprise High Performance Computing 15 SP3 wavpack Released
SUSE Linux Enterprise High Performance Computing 15 SP4 wavpack Released
SUSE Linux Enterprise Module for Basesystem 15 SP3 wavpack Released
SUSE Linux Enterprise Module for Basesystem 15 SP4 wavpack Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 wavpack Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 wavpack Released
SUSE Linux Enterprise Real Time 15 SP2 wavpack Released
SUSE Linux Enterprise Server 11 SP1 wavpack Not affected
SUSE Linux Enterprise Server 11 SP3 wavpack Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS wavpack Not affected
SUSE Linux Enterprise Server 12 SP2 BCL wavpack Not affected
SUSE Linux Enterprise Server 12 SP3 BCL wavpack Not affected
SUSE Linux Enterprise Server 12 SP3 ESPOS wavpack Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS wavpack Not affected
SUSE Linux Enterprise Server 12 SP4 ESPOS wavpack Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS wavpack Not affected
SUSE Linux Enterprise Server 12 SP5 wavpack Not affected
SUSE Linux Enterprise Server 15 ESPOS wavpack In progress
SUSE Linux Enterprise Server 15 LTSS wavpack In progress
SUSE Linux Enterprise Server 15 SP1 LTSS wavpack In progress
SUSE Linux Enterprise Server 15 SP2 LTSS wavpack In progress
SUSE Linux Enterprise Server 15 SP3 wavpack Released
SUSE Linux Enterprise Server 15 SP4 wavpack Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 wavpack In progress
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 wavpack In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP3 wavpack Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 wavpack Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 wavpack Not affected
SUSE Linux Enterprise Server for SAP Applications 15 wavpack In progress
SUSE Linux Enterprise Server for SAP Applications 15 SP1 wavpack In progress
SUSE Linux Enterprise Server for SAP Applications 15 SP2 wavpack In progress
SUSE Linux Enterprise Server for SAP Applications 15 SP3 wavpack Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 wavpack Released
SUSE Linux Enterprise Storage 7.1 wavpack Released
SUSE Manager Proxy 4.1 wavpack In progress
SUSE Manager Proxy 4.2 wavpack Released
SUSE Manager Proxy 4.3 wavpack Released
SUSE Manager Retail Branch Server 4.1 wavpack In progress
SUSE Manager Retail Branch Server 4.2 wavpack Released
SUSE Manager Retail Branch Server 4.3 wavpack Released
SUSE Manager Server 4.1 wavpack In progress
SUSE Manager Server 4.2 wavpack Released
SUSE Manager Server 4.3 wavpack Released
SUSE OpenStack Cloud 8 wavpack Not affected
SUSE OpenStack Cloud 9 wavpack Not affected
SUSE OpenStack Cloud Crowbar 8 wavpack Not affected
SUSE OpenStack Cloud Crowbar 9 wavpack Not affected