SUSE Support

Here When You Need Us

Attempt to bootstrap a client to a SUSE Manager 3 Server returns "Internal Server Error"

This document (7017994) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Manager 3

Situation

Attempting to bootstrap a new client to a SUSE Manager 3 returns the following at the bottom of the bootstrap output:

REGISTRATION
------------
* registering
An error has occurred:
rhn-plugin: Error communicating with server. The message was:
Internal Server Error
See /var/log/up2date for more information

*** Error: Registering the system failed.

Looking at the /var/log/apache2/error_log on the SUSE Manager server shows:

[Fri Aug 26 15:21:18.415612 2016] [wsgi:error] [pid 17191] IntegrityError: duplicate key value violates unique constraint "rhn_server_maid_uq"
[Fri Aug 26 15:21:18.415615 2016] [wsgi:error] [pid 17191] DETAIL:  Key (machine_id)=(xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx) already exists.

Where the x's represent the actual uuid of the system that is being bootstrapped.

Resolution

On the SLES 11 SPx clients exhibiting the issue enter the following as root:

rm /var/lib/dbus/machine-id
dbus-uuidgen --ensure

On SLES 12 SPx clients exhibit the issue enter the following as root:

rm /etc/machine-id
rm /var/lib/dbus/machine-id
dbus-uuidgen --ensure

systemd-machine-id-setup

The bootstrap should now run without the duplicate key issue.

Cause

With SUSE Manager 3 clients must now have unique uuids.  If you are cloning systems make sure to run the 2 commands above before attempting to bootstrap the client.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7017994
  • Creation Date: 29-Aug-2016
  • Modified Date:03-Mar-2020
    • SUSE Manager

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.