SUSE Support

Here When You Need Us

Pacemaker: manual resource migration

This document (000020246) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 12
SUSE Linux Enterprise High Availability Extension 12

Situation

Failback to cluster primary node from secondary node when the primary rebooted and came online.

Resolution

Check if cli-* constraints are put into the cib.

For example:
# crm configure show
...
location cli-prefer-<resource name> <resource name> role=Started inf: <node name>
...
If a cli-prefer constraints is present in the cib (see the example above), upon rejoin the cluster resource will be forced back to that node.

The constraint must be removed with the following command:
# crm resource unmigrate <resource | group>

Cause

The cli-* constraints are created in the cib when an user manually migrates a resource.  These constraints should always be removed from the cluster.  Normally users should use the unmigrate right after migrate.  The unmigrate will remove any cli-* constraints it adds to the cluster.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000020246
  • Creation Date: 14-May-2021
  • Modified Date:04-Jun-2024
    • SUSE Linux Enterprise High Availability Extension

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.