SUSE Support

Here When You Need Us

Fencing in Cloud Enviroment ( pacemaker Azure)

This document (000020363) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise High Availability Extension 15
SUSE Linux Enterprise High Availability Extension 12

Situation

If not using SBD as Fence Device in a cloud environment, the following should used as fence action for shutdown:
stonith-action=off

 

Resolution

To set the option issue the following command:
crm configure property stonith-action=off

Cause

If one uses the reboot option in a cloud environment, the hypervisor will generally issue a graceful shutdown to the Guest which might show like
hv_utils: Shutdown request received - graceful shutdown initiated
A graceful OS shutdown in a cluster environment is not a good idea as the cluster node is out of control and likely to hang on this shutdown.  Also, this means, in most cases, a controlled de-allocation by the hypervisor, which takes time and can lead to a timeout on the fence action for the fencing node, which would break the cluster.
 

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000020363
  • Creation Date: 12-Aug-2021
  • Modified Date:02-Sep-2021
    • SUSE Linux Enterprise High Availability Extension

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.